PUMA 3.4.1 Frequently Asked Questions

General remarks

The tool shall be used only for insurance business with deductibles according to standard market practice; in no case it is applicable to quotations for any type of cover on a non-proportional basis (such as excess of loss, difference in deductible);

Q: Which version of PUMA shall I use?

  • All new business should be quoted using PUMA 3.4.1.
  • PUMA 3.4.1 will not override the version currently installed on your PC. However, if multiple versions of PUMA (3.1.2, 3.2.3, 3.3.1,...) are installed on your PC or notebook, only the newest one will be fully usable with your new license. 
  • Older installations will remain on your computer but you will only be able to view quotes created in that older version. It is strongly recommended that you actively back-up all projects from any older versions either by printing them out or migrating them to the newest version (by using the Export/Import feature i.e. p2p files).

Q: I can't access Google Maps or Swiss RE CatNet®

  • Internet access will be necessary for having access to either public or Swiss Re web based tools (Google Maps, Swiss RE CatNet®).
  • A specific username and password will be necessary to have access on Swiss RE CatNet®: you can apply for your own credential at this link: http://www.asstech.com/en/catnet/extern.html. Please just note that it may take a few days to get access rights

Q: Does PUMA work on Windows 8, Mac, iPAD?

  • PUMA only works on Microsoft Windows® - XP, 7, 8 and 8.1. It may work on a Mac, under Windows emulation, but it has never been tested and is not supported. Same holds true for other operating systems.